fr   gb


Arbor
Le script Arbor > Généralités > Compatibilité

Compatibilité

Compatibilité, pré-requis et non-requis...

 

(o) PHP

Le code du script Arbor est compatible avec PHP 4.1 et ultérieurs.

(o) HTML

Le code Html généré par le script est compatible par défaut avec XHTML 1.0 strict / 1.1 ou, optionnellement, avec HTML 4.01 strict.

(o) MySQL

Arbor n'a pas besoin de MySQL pour s'exécuter.

(o) Javascript

Le code Html généré par le script ne contient aucun code Javascript/Ajax, Arbor fonctionnera donc tout à fait normalement si le visiteur a désactivé Javascript sur son navigateur.

(o) Cookies

Si les cookies sont refusés par le navigateur, Arbor fonctionnera tout à fait normalement en mode basé sur un "fichier de menu" mais ne fonctionnera que partiellement en mode "Explorateur de fichiers".

(o) Sessions

Arbor n'utilise pas les sessions PHP et peut donc être utilisé sans précaution particulière sur un site-hôte les utilisant.

(o) Moteurs de recherche :

L'utilisation d'Arbor pour générer le menu principal d'un site Web ne gène pas son indexation par les moteurs de recherche. Les menus, une fois générés, ne sont que de banals menus Html classiques parfaitement suivables par les robots indexeurs.

(o) L'utilisateur :

Une bonne connaissance de PHP n'est pas indispensable pour utiliser Arbor. Savoir comment intégrer un bout de code PHP dans du Html et connaître le b-a-ba de la syntaxe PHP sont suffisants, en s'aidant du mode d'emploi de ce site.

 

_________________

En bref...
Arbor n'ayant besoin ni de Javascript ni des sessions ni des cookies pour fonctionner et générant des menus indexables par les robots, est donc compatible avec une utilisation en menu principal de navigation d'un site Web.

 

 > Ce que peut faire Arbor

 

 

Arbor Home

 

Home Accueil

Contact Chercher

Contact Contact

Site Plan Plan du site

Page top Haut de page

Valid XHTML 1.0 Strict